Pourquoi utiliser jQuery Migrate Helper pour corriger les erreurs de WordPress 5.5 ? - Wenovio
1-844-WENOVIO English

Pourquoi utiliser jQuery Migrate Helper pour corriger les erreurs de WordPress 5.5 ?

Lecture de 3 minutes

La nouvelle version de WordPress 5.5

Si vous utilisez WordPress comme plateforme pour votre site Web, vous avez sûrement remarqué que WordPress est en constante évolution.

Les mises à jour sont parfois pour corriger des vulnérabilités et aussi pour améliorer les performances de la plateforme.

Le 11 Août 2020 l’équipe de WordPress a annoncée la sortie de la version 5.5 nommée « Eckstine ». C’est une version majeure qui apporte de nombreux changements, entre autres :

  1. L’intégration du Lazy-load des images.
  2. Un nouveau plan de site XML.
  3. La possibilité de faire des mises à jour automatiques pour les extensions et les thèmes.
  4. Mise à jour par téléchargement avec un fichier ZIP.

Source : https://wordpress.org/news/2020/08/eckstine/

WordPress a aussi abandonné quelques fonctionnalités tel l’outil de migration jQuery Migrate Helper qui ne sera plus activé par défaut.

L'erreur affiché par l'extension LayerSlider recommandant d'installer Enable jQuery Migrate Helper.

Qu’est-ce que jQuery Migrate Helper ?

jQuery Migrate Helper est une bibliothèque JavaScript qui permet d’utiliser des versions obsolètes de jQuery (c’est aussi une bibliothèque JavaScript) dans une application. Il permet ainsi d’utiliser d’anciennes versions de jQuery sur de nouvelles versions de WordPress.

Pour bien comprendre
C’est comme mettre de vieux pneus sur une nouvelle auto. L’auto pourra avancer, mais vous pourrez avoir des surprises sur la route si la chaussée est glissante.

Si une extension ou un thème utilise la version jQuery 1.7 dans son code, qu’à cela ne tienne, les anciennes versions de WordPress intégraient la bibliothèque jQuery Migrate Helper permettant ainsi à l’extension ou au thème de fonctionner correctement. Maintenant avec WordPress 5.5, l’extension ou le thème risque de ne plus fonctionner correctement ou avoir des comportements inattendus.

Comment faire si vous avez des difficultés après avoir installé la nouvelle version 5.5 de WordPress ?

  1. Vous pouvez installer l’extension Enable jQuery Migrate Helper.
  2. Ou faire une mise à jour vers la nouvelle version WordPress 5.5.1 qui apporte un correctif qui permet de ne pas afficher les erreurs du jQuery Migrate.

Pour finir

Faire la mise à jour de WordPress vers la nouvelle version 5.5 est un avantage certain, même si quelques sites rencontrent des erreurs. Comme je l’ai expliqué dans cet article, vous pouvez utiliser jQuery Migrate Helper pour corriger certaines de ces erreurs.

Un message affichera sur certaines pages indiquant les fichiers jQuery obsolètes utilisés par les extensions ou le thème :

Exemple d'une notification affichée par l'extension Enable jQuery Migrate Helper.

Nul besoin de s’inquiéter en voyant le message, ce n’est que pour vous avertir que certains fichiers sont obsolètes, mais fonctionnels grâce à jQuery Migrate Helper. Vous n’avez alors qu’à fermer l’avertissement avec le X en haut à droite.

L’équipe de Wenovio se fera un plaisir de vous aider si vous rencontrez des difficultés avec la nouvelle version de WordPress 5.5. Contactez-nous et un programmeur expérimenté pourra vous aider.

Laisser un commentaire

This site is protected by reCaptcha and the Google Privacy Policy and Terms of Service apply.